1.1.15b : Glasswire service stopped running

I’ve been using the beta for a while, and very much like it (and thinking about licensing Basic). I just upgraded from 1.0.40b to 1.1.15b, but now I can’t get GW to work at all. I tried stopping the service and deleting the services folder in ProgData, uninstalled, rebooted and re-installed. same problem. i searched the forum and found plenty of references to this, but nothing that seemed to show the problem had been fully resolved. Have I missed something?

(Win7 Pro 64-bit, Windows Firewall, AVAST)

Thanks, PAul


Please try the following again, even though it looks like you have tried some of this already:

  1. Stop the GlassWire service or kill the task with the task manager;
  2. Uninstall GlassWire with its uninstaller in add/remove programs;
  3. Remove\rename the C:\programdata\glasswire folder;
  4. Install our latest update;
  5. Please let us know whether these instructions were helpful.

Same issue here. I deleted the program files x86 folder, the subfolder in programdata, also removed instances of “glasswire” in the registry. Rebooted and same result.

Can you provide a link to the previous version? If that works then maybe at least we will have an idea as to the issue.


Same issue. Have uninstalled & reinstalled. Deleted folders. Still no joy. The Glasswire service just stops running. I can manually restart it and get glasswire running but then, for no reason that I can discern, it stops running.

1 Like

If you’re having this problem please answer these questions if you feel comfortable, or feel free to email them privately to our helpdesk email address.

  1. Your Windows version.

  2. Did you try installing GlassWire for the first time or were you updating it?

  3. Do you know the previous version of GlassWire you were using by chance?

  4. Do you know if your Windows Event log service is running? It should be running.

  5. Please install the latest Windows updates and try again.

Win 7 Home Premium, 64bit.
Upgrading from 1.1.15 no "B"
Windows Event Log is probably running, point me to where I can find a log.
Everything is up to date and running properly. Except Glasswire.

Can you email a link to the previous version, if that works then you at least know something about the current version.

  1.   I use Win7 Home Edition.
  2.   I was updating Glasswire.
  3.   I’ve updated Glasswire whenever it has informed me that there is a new version. At a guess, I’ve been using Glasswire for 6 months.
  4.   Yes, it is running.
  5.   Tried completely uninstalling and then reinstalling.  Same result as updating.  Tried uninstalling, rebooting and reinstalling.  Same result.

Please email our helpdesk if you’re having this problem. We have a custom software version we can email you to help us find this bug.


BUG: Every time Glasswire (1.1.15b) starts new (boot, etc.), the firewall-tab shows me grey symbols > firewall off and i can’t get it to run - as it always offs itself after a few seconds.
Indeed my windows firewall is running. With a trick i can bring it to run for the session:
W. firewall > off and on again. After that i can activate the firewall in Glasswire, so the symbols get colored.

Another issue: Glasswire doesn’t remove invalid firewall-rules/entries, nor can i delete those manually. For example for programs already deinstalled.

(Win7 Ultimate 64bit, 360 Total Security)
P.S. i cannot upload my screenshot as new user here!!!

1 Like

Please email our helpdesk so we can figure out what’s going on. Also, we’re working on adding the ability to delete apps from the firewall list. Thanks!

1 Like

Hello Ken,
nevermind this problem at my side as it’s not so important for me and probably only occuring on my special constellation. But if i can do anything to improve the software from bugs, i will do my best to help your team. Just email me back in this case, how i can help. :wink: Kurt

1 Like

Hello Glasswire-Team, Ken,

Finally i found out the problem. I deinstalled Glasswire and in the registry are still entries from your software remaining:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\GlassWire 1.1

But the real problem cause was the remaining folder (after deinstallation) with its databases:

There are in fact all firewall-rules stored and will be effective even after a new installation of Glasswire. I only got rid of my consisting problem, i described before, after i deleted this folder. Now its working well after a new installation.

Greetings, Kurt


I’ve downgraded to 1.0.45b and all is good. Had to uninstall the software as well as remove various files that weren’t removed by the uninstaller.

If our latest install still stops running for you can you email our helpdesk so I can give you a new version to test?

Same issue here, If I go back to the pre- version 1 version, it works like a charm.
It did work at first and I assumed it was the hibernating of my laptop.
But it seems it is every startup now.
Win 8.1SL
lenovo Y70-50

@gewgaw if you could email our helpdesk I could send you a new version to test so we can fix this.