Ask to Connect not remembered


#1

Version 2.0.78

I use Microsoft Edge to read saved documents on my computer, never to go on-line. With Ask to Connect enabled, Browser Broker keeps asking to access the Internet. I deny, but next day when I open the browser it asks again. Never seems to remember that I denied it.


#2

@garycurtin

When you check the browser broker by clicking on its icon with GlassWire’s firewall, does the file have the same location on your PC, or different locations? Thanks.


#3

No, the app is only listed once and it’s location is c:\windows\system32\browser_broker.exe.


#4

@garycurtin

When you installed, was it a clean install and did you choose the option to reset the Windows Firewall with our installer? We had another user with a similar problem and doing that fixed it, however I completely understand if you don’t want to lose your history/settings.


#5

No, I did not do a clean install. I need to keep my history, at least till the end of the month. I will keep that in mind to try then. Thanks.


#6

@garycurtin

In that case, don’t do a clean install but maybe try using our firewall settings clearing option instead. You’ll probably want to wait until the end of the month just in case though.


#7

I would like to report the same problem with 2 or 3 others Microsoft applications:

  • Microsoft Office Click-to-Run
  • Speech Runtime Executable
  • Wifitask
    Glasswire keeps asking regularly to connect to internet while I’ve already denied them.

#8

Since I installed 2.0.81 I have not had the problem and all Ask to Connects are remembered.


#9

Where did you find it? I only see 2.0.80 on the official website & download link.


#10

It is a beta version.


#11

Thank you for your reply and for the link.


#12

We plan to have an official update for 2.0 out on the 22nd.


#13

I came here to report exactly the same problem with the 2.0.80 version.

Some processes keep asking to connect even though I’ve already denied it. The processes version and path didn’t change at all.

I downgraded to version 1.2.121 and the problem doesn’t happen.

I’ll do a clean install of the 2.0.81b and see if it fixes this problem.


#14

@XeidiDent
@toriatama
@garycurtin

This is fixed now. Please update your GlassWire software https://www.glasswire.com/download/.

Consider using GlassWire’s “clean” install option and its Firewall reset option to solve the problem permanently.


#15

I tested the beta 2.0.81 and the problem didn’t happen.

Now I’ve upgraded to the version 2.0.84 and so far the problem didn’t happen either.

Thanks for the update.


#16

I am having the exact issue with 2.0.123 I thought it was just apps being updated but I checked versions and they are the same plus it appears to be doing it with ALL apps. I had to turn off ask to connect because every time I connected to wifi it auto blocked dns lookups and I had to re-approve all the apps again!


#17

Recently another person had this issue. They:

  1. Uninstalled GlassWire
  2. Went to the Windows Firewall control panel and chose “restore defaults”.
  3. Rebooted (important!!!)
  4. Reinstalled GlassWire using the “clean install” and “reset firewall” options

Then they let me know the issue was fixed. Please try it.


#18

That seems to have worked, no more double or triple prompts. Thank you!


#19

Thanks for sharing the good information.