Ask to Connect Question

I have been trying to understand how to use “Ask to Connect.” When I set the drop down to “Ask to Connect,” I see a GW alert that says, “Internet Connection Was Lost.” At that point, nothing on my machine will ask to connect or even actually connect to the Internet. The only way I can get my programs to connect is by either turning the firewall off or by setting it to “Click to Block.” I have tried reinstalling GW, using the method in the user guide to preserve my data: I save a copy of the data first and then delete my active data, uninstall GW, reinstall GW checking the checkboxes for clean install and default settings, uninstall GW again and delete the temporarily-created data, rename my saved data copy and reinstall GW again using my original, saved data. After that process, “Ask to Connect” still only blocks everything from connecting. My thought is that I am missing some important step, but I cannot see what that is, at this point. Should “Ask to Connect” force all programs wanting to connect to ask first? Thank you for your insight.

1 Like


GlassWire “Ask to connect” will ask you if you want an app to connect to the Internet with an “Allow” or “Deny” prompt.


It does not stop all network activity on your PC. That is very unusual and I don’t believe I recall anyone ever reporting that before. Our “Block all” mode is the mode that should block all network activity.


I see from your post you are trying to do a clean install of GlassWire to solve the issue. In this case it appears there is something wrong with your Windows Firewall API rules. For example, maybe you used another firewall application in the past that somehow caused issues with the Windows Firewall API.

To solve the issue you should probably uninstall GlassWire in add/remove programs, then go to the Windows Firewall control panel and choose “restore defaults”.

Now reinstall GlassWire with the “reset firewall” option checked. You’ll then need to turn “On” the GlassWire firewall, then you can activate our “Ask to connect” mode.

One potential problem that could have caused this is if you are using another firewall simultaneously with ours. I’d recommend removing that other software first before resetting the firewall. Some apps will add back their rules even after they have been removed from the Windows Firewall API.

Hi Ken, I followed the steps you gave me. The behavior did not change. “Click to Block” gives full connectivity but “Ask to Connect” does not allow anything to connect or even ask to connect. Plus, a GW alert tells me Internet connection was lost when the firewall changes to “Ask to Connect.” Could some kind of software program I am not aware of possibly hide a stealth firewall? This computer was new in January and has only ever run Windows Defender and Firewall. The computer did come with a trial of McAfee which I promptly uninstalled in January. Would it help to delete all the programs that are currently from the GW Firewall Tab and restart the GW service with the FW Tab in Ask to Connect mode, and let the programs ask when the time comes that they want to connect and add themselves to the FW Tab? Thank you.


Do you have an unusual type of Internet Service Provider that requires an app to send data out? Maybe there is some kind of application your ISP needs and it’s causing all network connectivity to come to a half in our “Ask to connect” mode?

You can try deleting the apps. That’s very strange.

If the problem continues I will ask my team if they have some ideas how this could be possible.

I turned off the GW firewall and deleted all the programs from the Firewall Tab. I selected “Ask to Connect,” restarted the computer and turned on the GW firewall. Then, a very few of the programs actually asked to connect. Internet Explorer was one of them but when I tried to go to a website, it complained that there was no Internet connection. I think those programs were just asking to connect to the local network. I tried many other network-accessing programs. None connected until I changed the mode dropdown to “Click to Block” and suddenly there were many “First Network Activity” alerts as programs began accessing the Internet one after the other. To answer your questions about my Internet provider, if there is some application of theirs running on my service, it would have to be located outside of my router’s firewall. I am not aware of any such thing. The only unusual thing I recall was when I first moved here and connected my computer directly to the Internet connection without a router. At that time, Glasswire showed me a large number of unfamiliar hosts in the Things Tab. After connecting my local router, those other hosts disappeared from Things. Now that it has been about an hour since I tried deleting the programs from the Firewall Tab, and about a half hour since resetting the mode to “Click to Block,” The Firewall Tab has filled up again with network programs and everything seems to be running smoothly. When I change the mode to “Ask to Connect,” I see an alert saying, “Internet Connection Was Lost.” I also tried the “Block All” mode which seems to work as expected, however. Thank you.


You are sure you’re using our latest version, correct?

Hi Ken, Yes I am using version 2.2.210.

1 Like


Our team said if you would turn on logging and recreate the issue then it might help us find the problem.

How do I turn on logging?

  • Stop the GlassWire service with the task manager under “services”.

  • Open the file: C:\ProgramData\GlassWire\service\glasswire.conf as administrator with Notepad.

  • Set parameter LogEnabled to “true” and save changes.

  • Start the GlassWire service again by right clicking under the task manager and services.

When the issue shows up again please send us the logs from C:\ProgramData\GlassWire\service\log as soon as the issue is reproduced. You can message me privately in the forum if you prefer, or email us

If you email please provide a link to this forum thread so I know what the logs are about. Thank you for reporting this issue.

Hi Ken, I sent the log via email just now. Thanks.

1 Like


I have it and I sent it to our team, thanks!

1 Like

I can confirm the same behavior on my Windows 10 and it is very annoying!

@csdfg2 @keerthi_a

What Windows version do you use? Is it possible to run Windows Update and see if there are any major updates available? Our team requested that you try this.

My Windows is Windows 10 Pro 1909 Build 18363.900. It is fully up-to-date. My Glasswire Version is 2.2.210


Would it be possible to try the suggestions listed above and see if it solves the issue for you?

@Ken_GlassWire I’m seeing the same issues when I open new programs like VMware Workstation and no pop-up from GW to allow to connect so I have to set it to “Click to Block” then a pop-up shows up and allows VMware to connect then I set back to “Ask to Connect” then it works fine so there is an issue that does not show a pop-up to allow a program to connect, there were a few other programs but can’t remember which ones then reading this thread said all I needed to know. Win 10 Pro x64 Build 2004.

GW version 2.2.210

There have always been a few apps that don’t always behave correctly with “Ask to connect” due to limitations with the API we use. @TripleHelix

I think @keerthi_a and @csdfg2 are saying our “Ask to connect” windows never appear at all.

I will investigate VMWare Workstation and see if we can recreate this issue, then fix it @TripleHelix. Thanks for your report.

Hi @Ken_GlassWire I understand and I have been seeing this issue and was wondering what was going on then i seen this thread then Opened VMware Workstation and it couldn’t connect as there was no pop-up to allow through GW but like I said a few other programs I had the same issue. I think Malwarebytes was one of them as well and again I would have to set to “Click to Block” then the pop-up would show but that auto allows the app to access the internet. I might install 2.2.210 over itself as a clean install and reset windows firewall.

This time it worked fine?






Yes, I was unable to recreate the issue either. It worked for me also. I’m glad it’s working! Maybe it was a previous version of GlassWire that had the problem.

Is it possible that this prblem is a permissions issue on some folder or file? Glasswire DB?