"Connecting to the local server"..fails

Installing the new version today, cannot launch Glasswire: “Connecting to the local server”…fails.

Earlier I was running 1.2 without problem, now I cannot even run the old release, it comes with the same error. I disabled the independent firewall to see, same result.

It seems many others have such problem since a few months, and it isn’t fixed yet?

Probably better to remove and use another software? :frowning:

I read this forum almost every day and I haven’t seen “many others” reporting this problem. I can only think of one other this year but maybe I’ve missed the ones you’re refering to. :confused: Anyway, the GlassWire team will know if this is a more widespread problem.

Also, most of the connection issues reported here are for remote connections which is monitoring GlassWire instances on other computers. That is different than the local connection problem you are reporting.


Sorry for the problem. Do you use any unusual security software that could be killing our service? Can you try downloading our latest installer and choosing the “clean” install option?

I disabled completely my firewall etc, have nothing else that could block some communication. “Clean install” the same, does not work. I even went to the reg database and deleted all keys relative to Glasswire before installing it again, no way.
Before, previous version worked fine, now I cannot even install it, does not work with the same error. The only new software I installed just before the new Glasswire is Microsoft NET framework in the last release 4.7 (win 7 64bits)

Your error message suggests that GlassWire.exe, the main window for GlassWire, is unable to communicate to the GlassWire services.

I know how frustrating problems like this are so I searched this forum for similar issues. You might like to try the following options that have helped to sort out similar problems for other users including myself.

Is GlassWire tray icon visible?

Do you have a GlassWire icon visible in your system tray (also called the notification area) at the righthand end of the task bar? If you do, then try restarting GlassWire

Is the GlassWire Control Service running?

If GlassWire still can’t connect then you can run Windows Task Manager to see if the GlassWire services are running and using CPU:

There are two GlassWire services that should be running:

  • GlassWire Computer Idle Monitor (GWIdlMon.exe)
  • GlassWire Control Service (GWCtlSrv.exe)

Restart the GlassWire Control Service

If the GlassWire Control Service won’t run then maybe try to restart it:

Is the Windows Firewall BFE service running?

If the GlassWire Control Service still won’t run then maybe check to see if the Windows Firewall Base Filtering Engine (BFE) is running:


Thank you for the report. I’ll ask our team if they can recreate this. So far I have not seen any other reports of this problem so please try the things Remah suggested above if possible.

I have also been having this problem since updating to 1.2.102. Going to try a full uninstall/reinstall.

Full clean reinstall worked.

1 Like


I’m glad it worked. Sorry for the problem. Did you recently do any major Windows updates? Perhaps it’s related somehow.

Well, full “clean” reinstall did not help, as working on the Service (that was already working, by the way). BFE was already in “automatic” mode, and was running, antivirus (DrWeb) was fully disabled then uninstalled (!), Glasswire control service could NOT start (no right, though I am on an admin account), etc etc.

I gave up, will maybe have a look at a future release.


If you restart the GlassWire service like Remah recommends above does it solve it?

GW icon: yes there is.
GW control service: cannot start (“Access denied”, though I have admin account)
Restart GW: Does not change anything
NO services like “GlassWire Computer Idle Monitor (GWIdlMon.exe)” and "GlassWire Control Service (GWCtlSrv.exe)"
Windos BFE IS running

Can restart XXX times, clean install XXX times, nothing changes.

The GlassWire team will have to look at this.

I don’t understand how the icon can be visible without the services running.

I have had the same. A clean install solved the problem