GlassWire 2.2.291 now available - See process IDs and services

We’ve just released a major GlassWire update (version 2.2.291).

This update allows you to see processes and process IDs related to apps on GlassWire’s firewall tab. Get it now on our download page.

Other changes are below. GlassWire Software Version Changes List

  • You can now see services and process IDs related to your apps on GlassWire’s Firewall.
  • Added a warning for our firewall “block all” mode, so a user who is using our remote monitoring feature will know they are about to block their own connection.
  • Removed an option to not show the ports on the firewall tab. This option is now on by default for everyone.
  • Fixed a bug that could cause some remote access addresses to not be saved in GlassWire’s settings.
  • Fixed a bug where a graph pop-up could show zero stats in some situations.
  • Fixed a bug where the mini viewer had an alert bubble that could overlap its header.
  • Fixed a crash (reported in our forum) that could be caused by running an app from a network storage device.
  • Fixed a bug that could cause an app started on a network share to be unblockable.
  • Fixed a crash that could be caused by VirusTotal scanning when an app is on a network share.
  • Fixed an issue that causes all apps to be blocked on the firewall if “ask to connect” is enabled, and if the GlassWire database is moved from one PC to another.

Please give this major update a try and let us know if you experience any issues. We’d like to thank the GlassWire users who gave us feedback in the forum and reported issues so we could fix them.

1 Like

It’s surprising and disappointing that it’s even necessary to ask, considering that it’s such a major issue that’s been discussed so prominently in the forums, but I have to ask as it’s not even mentioned in the changelog:

Does it address the very well known issue that affects people who installed the problematic v2.2.258, whereby that specific version wiped out settings and history, in such a way that every subsequent version installed on a such a machine (i.e. one which had v2.2.258 at some point) also wipes out settings and history?

Does this new version have a proper fix for that major issue so that it is safe to install on such an affected machine?


Sorry for the issue you experienced with version 2.2.258 that was released in October of 2020. Version 2.2.258 was released for two days and no users were ever asked to update via an update alert.

Of course it’s still unacceptable that any version could cause user settings to be lost and I apologize.

You can see in our change list (click the link below) that version 2.2.258 was released on October 6, then the fix was released two days later on October 8. On the change list we also link so the fix for the problem that we posted here in the forum. GlassWire Software Version Changes List

Once the problem was found we put out a fix within 2 days and we posted a solution in the forum and we also included a direct link on the change list itself.

We will work hard to improve in the future so this won’t happen again. Please check the solution above and let me know if it’s acceptable to you or not.

Also just to be clear, the history was never wiped out, but instead was moved to another directory and the can be saved.


I don’t see any solution offered in your reply. As you are well aware, installing v2.2.260 over v2.2.258 doesn’t solve anything, so why you try to point me to a so-called “solution” in the v2.2.260 changelog is a mystery.

So you’re saying that people who installed v2.2.258 are now SOL? Because, as you know, every time any version is installed now, the problem is repeated again, causing major hassle.

Your comments about no users being asked to update is rather tone-deaf and actually quite insulting. I installed a non-beta, public release that you made available on your website. It was because of people like me installing that version and then posting details of the bug that you were able to make changes for v2.2.260 to avoid the problem for other people. But you’ve since never solved the problem in any subsequent release to reverse what v2.2.258 did on machines like mine that it was installed on.

So GlassWire screwed up my installation with the publicly-released version v2.2.258 and now you offer no solution to get my installation back on track. You expect me to just put up with having a GlassWire installation that gets affected in the same way every time a new version is released.

You guys have washed your hands of this and are not prepared to fix installs that have been broken by v2.2.258. Wow.

I am very sorry for the issue with 2.2.258. I have opened a new ticket with our team so I can understand the issue better to suggest a solution for you. I will post a reply here when I hear back.

I think that in part this is the same issue that I described where data is lost:

But losing settings including things labels are further problems.

1 Like

Our QA installed installed 2.2.258 (clean) then installed 2.2.291 over 2.2.258. All my settings, alerts, blocked apps, virus total reports were converted with no issues.

Our QA asked if you lost your settings when updating to 2.2.291, or did you feel this might happen so you did not try it yet? @harkonnen

Thanks for your report.


I will also ask our team if there is a solution to your problem that you had. I think for us to investigate we might need to ask you to send your actual databases if you’d feel comfortable doing so?

Okey. There is quite an improvement.
Now the the control process is not running indifintely into a loop and using 6% of one of my high end cpu.
And so the improvements tôt je database engine made the job. It doesn’t give a null value anymore when it encounters a problem.
Now it just crashes as it supposed to be.

Still a lot of crashes though but we are on the right road now. The database was one of the big problem which seems to be now more or less resolved.
Do you want the crash dumps ?


We worked with several users to improve resource usage.

If you have a .dmp, please email it to us using a cloud service.

Noted there is 2 config in the shared folder

Best regards

1 Like


I responded, but please leave it up for awhile so someone on our team can get it. Thanks for your help.