GlassWire blocks legitimate svchost, completely blocking internet access


I do not understand why this is happening
GlassWire creates a rule, on its own, that blocks svchost - both inbound and outbound:

it happens mostly when I switch from my Linux Ubuntu distro back to Windows; but I seen it happening in other circumstances, so far I can’t reproduce it reliably



Strange, I have never seen this before. Are you in Ask to connect mode?


yes, I’m in ask to connect mode


I got it to reproduce: it does this every time I disable then enable the GW firewall

GlassWire has a problem with me adding and removing HDDs

I experienced this too. I just went under properties to change the action from blocked to allow. I have my set as “ask to connect”.

Also, I keep getting this pop up from Glasswire to download update. When I click on it there is no update? What’s up with that?



The link should open your browser and take you to our download page. Does the link not do that when you click on it, or what happens exactly when you click the link or button?


I first get a pop up on my desktop. It says Glasswire update is ready. I press the button and leads me to the page where it says in the middle of the page in a red block, download Glasswire for free. I see nothing about updates???



You must press the download button, then download our software to your desktop, then install it over the current version and it will be updated. We are working on auto-updates but it is not ready yet.



Thank you, I did. When you install glasswire it uninstalls the old one then adds the downloaded version. Just thought I’d let you know.



That’s how it should work. Thank you for confirming and I hope everything is working well for you now.


Hi, @Ken_GlassWire just want to update you that I see glasswire updates coming through the firewall. :+1: