Glasswire blocks Linux subsystem for windows 10 (solved)


#1

So, just installed the anniversary update for windows 10 and enabled the Linux subsystem. But found out Glasswire’s “Ask To Connect” setting blocks internet to bash/the console. i.imgur.com/RPn5ku4.png

Click to block does not do this.
A̶n̶d̶ ̶i̶t̶ ̶d̶o̶e̶s̶ ̶n̶o̶t̶ ̶d̶i̶s̶p̶l̶a̶y̶ ̶o̶n̶ ̶t̶h̶e̶ ̶f̶i̶r̶e̶w̶a̶l̶l̶ ̶p̶a̶g̶e̶,̶ ̶s̶o̶ ̶y̶o̶u̶ ̶c̶a̶n̶t̶ ̶u̶n̶b̶l̶o̶c̶k̶/̶b̶l̶o̶c̶k̶ ̶i̶t̶ ̶t̶h̶a̶t̶ ̶w̶a̶y̶.̶
Fixed edit: im quite sure its Pico i.imgur.com/vFeZ87g.png thats blocked even if its unblocked.

Did a clean install to be sure and had everything unblocked, but it was still blocked.


#2

UPDATE: Use the latest version of Windows 10 (the October 2018 update) and this problem is now solved. Use Windows Update.


#3

I got the new update just before i posted, it was what i did a clean install with. (Delete all old settings option)

I do get notices from other programs, i dont know if i get a notice for bash.

It may be a bug with bash and how it reacts to windows firewall, since its still in beta.


#4

Thanks, we’ll check it out and try to reproduce and fix this.


#5

I am seeing the exact same behavior. Brand new installation.

Ask to connect mode blocks the Linux subsystem even if “pico” and “Microsoft Lxss Subsystem Tool” is unblocked. It does not detect activity from “bash” or any other application.

Switching to Click To Block works, as stated by the reporting user and all traffic reported comes from “pico” and “Microsoft Lxss Subsystem Tool”


#6

Any news about it? Just bought it and have the same problem.


#7

This feature is new and I believe it’s still in beta? We will continue to try to figure out a way to make it work but Microsoft doesn’t make it easy unfortunately.


#8

Not sure why but this is definitely affected by clean installation. Installed GW again recently after ~12 months without it. It picked up my old settings and everything worked fine - “ask to connect” correctly allowed bash connections.

Did a clean install earlier this week and suddenly all stopped. Bash no longer connects.

Hope this helps a little :slight_smile:


#9

@nazwa

I believe this software is still in beta, but when Microsoft finally finalizes it we’ll do our best to add support! It’s a big complicated how it works, so we’d prefer not to spend major time on it then find they changed it completely before the final version. Thanks for your patience!


#10

See this article about how Microsoft wants to make interacting with firewall software etc. easier in the next version (which should be out in spring):

I hope you guys will be able to support this asap, as I have Glasswire off since WSL was introduced (unfortunately).


#11

@codex22

Thank you. I will send this to our dev team.


#12

I also am having the same issue, this would be great since I just ponied up for the license :slight_smile:


#13

Having the same issue here with Pro v1.2.79
Any ETA on resolution?


#14

The solution is not as easy as we hoped, but we’re still working on figuring it out. Thanks for your patience.


#15

Hate being that guy, but any luck? Elite customer who would love for this to work, or at least know it’s still in the pipe. :slight_smile:


#16

@the-trooper

We’re still trying to figure it out. It’s in beta for Windows still I think, so they are changing it quite a bit.


#17

Any news on this?
Recently bought GlassWire Elite and love it. It’s the best Firewall for Windows (even when some Features are missing in comparison to Little Snitch on macOS).
But it’s very annoying that the Linux subsystem on Windows is always blocked.

As @kk2 mentioned, from my point of view it is the Pico process. But it feels a little bit strange as no executable is shown or other details. It’s always blocked no matter in which state it’s actually is.
The only workaround I found, was turning off the firewall by using the OFF button on the firewall tab. But of course all other rules are then disabled, too…


#18

@caldicot

I think this software is still not final, and we’re having some technical problems working with it as it changes. Sorry for the problem.


#19

Hallo @Ken_GlassWire,

thanks for your quick reply.
I understand that it’s tough for developers to keep on a level playingfield, especially as MS has increased the speed of development since Windows 10.
But on the other hand your answer feels to me, that you have given up on supporting the linux subsystem until it leaves the beta stadium. That would be a pity, as from my point of view MS takes the subsystem very serious, even if they leave it in beta stadium for a long time …

Is there at least any workaround thinkable? Is it possible to always allow the Bash to connect to the network? As I said I can disable the whole firewall, but I hate doing it …


#20

We use a WIndows API for blocking, and this API they make does not work with their own Linux subsystem. I’m not sure what we can do about it but we’ll keep trying. Sorry for the problem.