GlassWire - Version 1.2.54 beta can't connect

Uninstalled 1.1.41b and deleted Glasswire folder in ProgramData.

Installed Version 1.2.54 beta and got ‘can’t connect’ (The Glasswire service stopped running).

Uninstalled, cleared the folder in ProgramData, rebooted and installed 1.2.54 again, same error.

Rebooted and returned to 1.1.41b and that works fine.

Also both times my GlassWire Pro Serial Number wasn’t saved so I’ve used up all three of the keys I bought, could this be reset please.

@DeltaWhiskey Your key is reset, please try it now.

I reported this error to the dev team to see what they suggest next.

I just installed GlassWire on Windows 10 and the service won’t start. I have cleared the ProgramData folder and reinstalled.

Edit: Is the 1.1.41b version available somewhere so I might try that?

Thank you for resetting the key, that’s fine now.

Hopefully the dev team can come up with a fix for me, thanks for the fast response.

1 Like

I got the same error,and the 1.1.41b works well。

Same problem here, reinstalled, cleared programdata\glasswire, reinstalled again and cant connect to service

Are you able to find crash dumps on your desktop? If so can you send them to us?

No .dmp on the desktop. Checked for .dmp files on the C drive, nothing related to Glasswire found.

@DeltaWhiskey Please check if GWCtlSrv.exe is running and let me know what you find.

I’m back on v 1.1.41b so it is running.
If you want I can uninstall that, clear ProgData folder and install 1.2.54 again to see if GWCtlSrv.exe runs then.

@DeltaWhiskey We’d really appreciate you trying that, thank you.

OK, I’ll do it now. Get back to you soon.

Running System Explorer (

Installed Version 1.2.54 beta and got ‘can’t connect’ (The Glasswire service stopped running).

When I clicked on ‘restart glasswire’ I saw GWCtlSrv.exe start up but after a few seconds it disappeared from the process list. I tried this a few times, each time GWCtlSrv.exe appeared on the process list then dissappeared again after two seconds.

Thanks. Let me see what the team recommends next.


Could you put the attached log.conf file in the c:\programdata\glasswire\service folder and start the GW service again. Also you should not push the Connect button right after the service was started. Please wait for a while and see whether the service keeps running if the UI stays disconnected.

You should then send us the logs that will be stored in the c:\programdata\glasswire\service\logs folder “help” or “bugs” emails are fine.

No issues here and I just installed over the last version and it’s working great! Windows 10 x64 Enterprise.

Daniel :sunglasses:

Microsoft MVP Consumer Security

1 Like

May I suggest uninstall Glasswire with Revo Uninstaller Pro 30 day Trial in Advance mode and delete everything it finds then reboot and install Glasswire v1.2.54b as that helped a few users I know!

Daniel :wink:

Microsoft MVP Consumer Security

1 Like

All done and log file sent.

As far as I can tell from the reports of problems, all the users apparently uninstalled 1.1.41b prior to installing 1.2.54b. Could that somehow be related? In other words, try leaving 1.1.41b installed and allow the new installer to remove it. If you want to remove the history, use the function provided in Settings.

I’ve been testing the alpha releases through the previous 1.2.53b. I usually install the newer release over the existing release. That’s what I did with 1.2.54b and like TripleHelix, no issues at all. All my network machines are reporting properly as show in this mini-view. All tabs work and all functions that I’ve checked are fine. My remote sessions (shown below) all re-started immediately when the new release activated.

1 Like

Initially, I installed 1.2.54b over the existing 1.1.41b.
When it came up with the ‘can’t connect’ error, I uninstalled 1.2.54b, cleaned out the ProgramData folder, rebooted and tried a clean install with the same error. Uninstalled 1.2.54b again, cleaned out ProgramData, rebooted and reinstalled 1.1.41b which works fine.

1 Like