Issue with Glasswire and Flight Simulator


I’m glad it’s working for you. Hopefully @shadeless will see the same. Nice skin by the way. :+1:

Ok so I downloaded the new GW version and flightsimulator.exe is now shown and traffic is logged - but only when Firewall is disabled! So not really fixed unfortunately :frowning:

Here is what I did/steps to reproduce:

  • I finished downloading Flightsimulator with the old version with GW Firewall turned off. After the dl had finished, I closed the game.

  • I installed the new version 2.2.241 over the old version. In the install dialog, i chose clean install and reset ms firewall (sorry don’t remember the exact wording)

  • I started GW and turned on the firewall and enabled ask to connect

  • I launched Flight Simulator and got the GW popup that asked me to either allow or deny access.

  • I pressed allow in the popup. The game continued launching but had no network connectivity.

  • I restarted the game because sometimes if you don’T give an application access in time, it times out. But restarting didn’t help - still no connectivity. I closed Flight simulator again

  • I turned Firewall off in the glasswire settings and launched FS

  • now i got the “first network activity popup” from glasswire and suddenly, the traffic was logged in the graph. The game had network connectivity again.

  • So i closed the game again, re-enabled firewall and launched it. But the same issue as before occured - no more traffic in the graph and the game had no connection.

So in conclusion, as soon as the firewall is turned on, traffic doesn’t get registered and the game has no connection. When FW is turned off, everything is fine and paradoxically, the traffic is registered.

One strange thing I noticed is, that the application path is messed up or doesn’t resolve like the other apps, Virustotal analysis also fails:

Any ideas?

1 Like


The firewall is in no way connected to traffic monitoring, so what you’re saying should be technically impossible. Firewall settings should not matter when it comes to monitoring traffic because it’s a completely different API that’s used and it can’t cause issues with the network monitoring. It’s more likely there just isn’t any traffic because the game is blocked.

@bebramsa Is your firewall on or off?

I will report this to our team. Thanks for these details.

@Ken_GlassWire I haven’t enabled the firewall yet, I’ll test it out later if I get a chance!

1 Like

From an old fan of MS Flight Simulator, I thought MS shut down the Windows game studios years ago? Any news to share?

Hello. Thank you for a great program.

I have the excact same issue with Flight Sim, firewall enabled, ask to connect.
Glasswire 2.2.210
Windows 10 - 2004 (Build 19041.450)

1 Like

@conanandre @bebramsa @shadeless

We need your help to solve the issue. We see the game is paid, so we see we need to buy it to test. We were hoping maybe you could help us before we buy the game. Could you send us logs?

Hey Ken,

i tried collecting logs, but after stopping GlassWire Control service, placing log.conf, starting everything again and reproducing the issue, the log folder is empty.
I think I did everything correctly, also tried specifying a different path within log.conf.

Not sure what I’m doing wrong.

Is it possible the .conf file you created ends in .txt? It should end in .conf.

It is definitely ending in .conf, i have file extensions enabled always (you can see the other extensions in the screenshot).
Log level -1 is correct, right?


Yes, that is correct. I will ask our team if they have some ideas.

1 Like

Same problem here, when the firewall is on it doesn’t connect even releasing MFS 2020.

1 Like


In case you missed it, please be sure you’re using our latest software. It does solve the issue for some problems with this game, but not all the issues.

We are actively investigating this issue.

Just checking in to see if someone could send us logs for this. It will help us diagnose the issue.


I’m embarrassed to say I sent you logging instructions for our older software. Please do this instead:

  • Install the latest GlassWire version.

  • Stop the GlassWire service at the Services tab of the Task Manager.

  • Open C:\ProgramData\GlassWire\service\glasswire.conf as Administrator.

  • You should not add anything to that file, just change a single parameter: LogEnabled = true

  • Then you should save the file and restart the GlassWire service.

  • The log will appear immediately after the service startup.

  • Then you should repeat the problem and send us the logs.

Hi I’m having the exact same problem with the latest version of glasswire, 2.2.241
its same problem with MS flight sim and a number of other “microsoft store” games.

log says …
28.20:30:05 [ERROR] glasswire::win::firewall::AddRule:713: Firewall. Rule adding failed: {}, app: \?\globalroot\device\harddiskvolume13\flightsimulator.exe
29.20:30:05 [HINT] glasswire::win::FirewallEngineWin::AddRules:227: error: 80070057
30.20:30:05 [ERROR] glasswire::win::firewall::AddRule:713: Firewall. Rule adding failed: {GlassWire.out.app_-1856714697.profile_1.mode_2}, app: \?\globalroot\device\harddiskvolume13\flightsimulator.exe
31.20:30:05 [HINT] glasswire::win::FirewallEngineWin::AddRules:227: error: 80070057

… happy to send the log somewhere if you tell me how


Thanks, I will share these with the team.

With the new instructions, I managed to also get some logs. They show the same thing as Trekkys.
I also tried scanning the app again with the integrated virustotal scanner which also shows in the log.
In my unqalified opinion, I’m pretty sure the issue is the strange path formatting that leads to issues when trying to add the rule to the windows firewall ruleset (and scanning in virustotal)

26.19:01:07 [ERROR] glasswire::win::firewall::AddRule:713: Firewall. Rule adding failed: {}, app: \?\globalroot\device\harddiskvolume12\flightsimulator.exe
27.19:01:07 [HINT] glasswire::win::FirewallEngineWin::AddRules:227: error: 80070057
28.19:01:07 [ERROR] glasswire::win::firewall::AddRule:713: Firewall. Rule adding failed: {GlassWire.out.app_-73490274.profile_1.mode_2}, app: \?\globalroot\device\harddiskvolume12\flightsimulator.exe
29.19:01:07 [HINT] glasswire::win::FirewallEngineWin::AddRules:227: error: 80070057
30.19:01:13 [EVENT] Client session connected. Sid: 3, type: 2, protocol: 3, os: 1, version:, bound:, remote:, region: ‘’
31.19:01:37 [ERROR] glasswire::ScanTaskPrivate::GetAppHash:90: app hash calculation failed: \?\globalroot\device\harddiskvolume12\flightsimulator.exe
32.19:01:40 [EVENT] Client session connected. Sid: 4, type: 3, protocol: 3, os: 1, version:, bound:, remote:, region: ‘’
33.19:03:57 [INET] TcpClient. Receive error: short read


Please send the full log file as an attachment to our helpdesk email. It appears we cannot get all the info we need from the copy/paste for some reason.

I’ve now bought an Elite license so if you need more firewall logs etc. then let me know!