Issue with nord vpn

Hi, I changed my VPN provider to Nord vpn , and since then , glasswire firewall hasn’t been working properly , I have internet and all , but glasswire firewall just won’t work when connected to a server , even when an app is set at block on glasswire , it’s still working, moreover I’m not getting the popup in click to connect mode aswell glasswire is however working fine when the vpn isn’t connected , is there a fix around that?

That’s an odd issue, I use ExpressVPN and haven’t had a single issue. I wouldn’t recommend using Nord depending on what your activities are. They fall under jurisdiction of the EYES!! No matter what there company policy is they have to provide data to the US Gov, and they don’t have to tell you jack.

well I was using express before but I can’t afford it right now, and yes , i’d rather use express, but here I am with this odd issue

I’ve never used Nord because of the above lol but have you tried changing locations? if they offer the ability.

mhmm gimme a minute
still doesn’t work , guess someone’s gonna use the 30 day money back warranty , is private internet access good?
like I know we got a 50%discount with glasswire on this vpn


Are you having an issue with our Android app or our Windows app? Sorry for the problem. I think it’s the Windows software?

We’ll check the latest Nord Windows software and see if we can reproduce this. Thanks for your report.

Nope, not IMO. They fall under the same jurisdiction. Any company hosted (or formed) within the USA will be affected.

Maybe this would help :smiley:

Sorry if I violated the laws ADMINS!!! nothing but respect :smiley:

1 Like

Didn’t think to ask the platform!

yes it is the windows desktop app image

1 Like

and I do know about the eyes thing , I’m just broke lmao ^^

1 Like

Maybe try changing the DNS in Windows. I would just use google DNS for now. and

To change the DNS settings on your Windows 10 device using Control Panel, do the following:

Open Control Panel.
Click on Network and Internet.
Click on Network and Sharing Center.

On the left pane, click on Change adapter settings.

Right-click the network interface connected to the internet, and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) from the list.

Click the Properties button.

Click the Use the following DNS server addresses option. ( and

Click OK.

Click Close to apply the new DNS settings to the adapter.

well ,I’d think about a dns issue , if I had problem connecting , but right now, i’m facing the opposite , problem not connecting , Like glasswire firewall not working

also based on your link , nord vpn is based in panama , which is outside of the 14 eyes

Didn’t realize that, I’ve just heard some shady things about it. I would just start cycling through all of the locations. DNS was just a suggestion, I’ve seen some odd things fix issues in the past. Just trying everything :smiley:

most of the issues could definitely be user error, or not properly connecting, ex…

According to that website, NordVPN is recommended…It is based in Panama…

1 Like

Little recommendation, to keep things clean in forums especially threads that have died many try not to post things that have already been said, or if you do want to add something to an old thread maybe add your own insight to things to help resolve whatever the issue may be.

Didn’t realize how long ago the post was made, just responded…sorry…I have been using Nord for a long time on many of my devices that I use to access the web…especially at hotspots…I have had no issues with it…

1 Like

I can confirm I’m having same problems with glasswire and NordVPN

firewall just won’t work when connected to a NordVPN server, it lets blocked apps pass through.

Glasswire has trouble connecting to its service when the computer is connected to NordVPN.

Disconnect from NordVPN and everything works as intended

If you are having issues with the NordVPN software, they also give a way to use other VPN software (or the built in Windows software) to use their service.

Thank You

GlassWire’s firewall works very well when connecting to NordVPN using IKEv2/IPsec

It seems to be the NordVPN app that causes the trouble.

1 Like