[SOLVED] QT5core.dll and msvcp140.dll missing and GW won't run


#1

This problem began this morning when I started my computer. Very frustrating! Why did this happen?!

I had to try and reinstall GW two times, and neither time worked. So, I had to uninstall the problem, then do a reinstall, and I still am getting the msvcp140.dll error.

So I found msvcp140.dll elsewhere on my system and moved it into GW folder, and then GW started complaining about missing QT5core.dll again.

What am I supposed to do to fix this problem?


#2

@stealthmode

Do you use any cleaning software to clean your hard drive? Sometimes these types of apps can delete our files. If that’s what happened you’ll have to do a clean install of GlassWire.

The only other thing that could cause this is some kind of file corruption issue. I haven’t seen this reported before and it doesn’t seem to be a common problem.

If you reboot does it help?


#3

It’s none of those.

I found the issue. It’s Visual C++ Redistributable 2015 (x86). I’m on a x64 machine, Windows 10 1709 16299.431. Yesterday it seems that program was updated automatically, I assume beucase it doesn’t show up in my Windows update history. Because it shows an install date of 7/1/2018, but I didn’t install it yesterday.

I realized it also affected MS Word, Excel, etc., after I wrote this thread.

Running modify from the app profile and choosing to repair it fixed the problem.


#4

FWIW, I did a clean install of GW and that didn’t help. I also uninstalled GW, deleted any remaining files and registry entries, then reinstalled GW, and that also didn’t help.


#5

I’m glad everything is OK now. Thanks for the details!