Try the GlassWire Windows 2.0.81 beta!

After another reboot the Apps seam to be fine so it has to do with something on a clean reinstall and first reboot IMO.

In the Picture below I want these two Blocked!

Confirmed on a second system after first reboot on a clean reinstall of the beta.

Hi Ken
OS Version is Windows 7 and VMware workstation 14 Screen 1920 x 1200
Note it seems the screen resolution does change depending on the size of the window at the time. The size i mentioned above was full screen. DPI is set Smaller 100% (default)

Does the new beta resolve the Trojan issue or has that not been resolved yet. Even though it’s a false positive, it’s annoying when windows security keeps giving the false alarm


It should resolve it if you don’t block Windows Defender, but if you block it from accessing the network, it reappears. We’re looking at some other options to stop this.

Please keep the betas publicly accessible like many (most?) other service program sites do! It makes testing more accessible.

1 Like

Any news on a newer version with a fixes that we have issues with?



So far no major issues on the Beta.

Using profiles is a little clunky, so as I “tune” a profile, and I make a “good” change, then I go back to the profile and check the “use current profile rules”.

So, I’ve created a few profiles to allow specific programs to update.

Like all beta software, nothing is perfect, but I’m a lot happier with Glasswire on my computer than without it. The ability to block stupid windows stuff, cortana, “hidden” system tasks, etc. is priceless.


1 Like


First, happy new year. Sorry for coming late to the thread.

I just installed this beta version on my home server, and recorded the whole process on video. As you can see, upon first run the scan tab was already active and reported active nodes on my home network, without me ever touching anything in settings. Moreover, I was not able to find any option to disable it in the settings window (did you change the name or location of this feature again?).

Despite showing the items as blurred, GlassWire is still scanning my network. After I stopped recording, I clicked the scan button again, and it scanned the network again. I couldn’t find how to turn this feature off (as in, disable it so that even clicking the button won’t make it scan my network).



We use two different techniques to check for “Things” on the network. GlassWire uses one technique after its installation that is not very invasive and shouldn’t cause any security alerts.

Then if you press “scan” or choose to turn on the Things scan we use a secondary type of system to scan in detail that gives more accurate results.

We have always had the first time of scan since the original version of GlassWire and nobody has complained that I remember, so that’s why we do one scan with that method after install.


Would it be too difficult to disable it? I mean having an option in settings that disables the functionality, so that even if the button is clicked accidentally, it will not scan the network.

May I also ask if by “not very invasive” you mean doing an ARP scan? If so, please note that Cisco and most other enterprise switches that support NetFlow which will report ARP scans and will trigger an alert in network management software and IDS that integrate NetFlow reports. Now I am pretty sure this is what triggered the alerts at my hosting provider.


The second scan type that you must trigger yourself is an ARP Scan, but the other list of “Things” is generated by something that all Windows PCs do automatically with the ARP table so it should not trigger anything. I watched the video and I did not see the scan update again, unless I missed it?

It didn’t update again. I wanted to see the traffic, so I ran WireShark and clicked the scan button to see what was happening on the wire.


What did Wireshark show?

I ran wireshark on my home server (on my home network) and pressed the scan button to see what happened, which is how I caught the ARP scan. Mind you, I do have network discovery enabled at home.


That’s correct, if you press “scan” you will see an ARP scan, but GlassWire does no ARP scan unless the button is pressed or unless you turn it on to automatically scan in GlassWire’s general settings. The default first scan GlassWire uses is not an ARP scan and shouldn’t trigger any alarms.

Win7 Home “SP2” x64
Glasswire Pro

Ever since v2 there had been some annoyances which I was hoping would have been cleared up in .80.

However, these have been rearing up on occasion:

  1. Previous apps gray flamed become flamed. On loosing the app’s connectivity I have to find the app and click on the flame to gray it.

  2. All internet connectivity is lost. I have to turn off the firewall and turn it back on again (the green on off button).

  3. Bogus First Network Access: Since installing .80 the day it was released, this just started happening yesterday. In this example, qlock was previously gray flamed. Note it is flamed while the First Network activity before Allow is clicked. Upon clicking Allow, the app becomes gray flamed.

This is happening on a regular basis for my Mozilla browser, email notifier (pop peeper) and RSS reader (quiteRSS). And once so far for Bitdefender updater, my anti-ransomware app! As usual, these are not logged in Alerts.

I just installed .81b over .80 and rebooted which I hope will fix all that. I avoided the complete uninstall/re-install or the clean/reset install as I am growing weary of doing that.

I’ll report back upon determination. Cheers.


If we added an admin lock icon (kind of like GlassWire’s settings) to the scan option in GlassWire’s settings would that solve the issue for you, or is that not the problem you are having? Our team wanted to know.

We wondered if you were worried a user on your network may scan and cause the problem and if you wanted to block them from doing so.

Thanks again for all your testing help. We plan to have a major update out soon.

The real update is now out at