Use system locale for date and time format


#1

I notice that the Usage tab lists the time and date in US format (using terms such as AM and PM).

I suggest having Glasswire check the locale of the system the software is running on and then using the correct time and date format. For example, here in the UK (and in Europe, I believe, and much of the rest of the world), we use 24-hour time. Also, our locale is such that we put the day before the month.

So instead of seeing the US date and time format of ‘Apr 29, 2017 12:00 AM’ in the header section of the Usage tab, I would expect to see the UK equivalent, which is ‘29 Apr 2017 00:00’.

EDIT: And actually, this should apply to the rest of the application too. All over the place, in various other tabs too, I see the times and dates are currently all in US format.


#2

@harkonnen

GlassWire should check the language and show the correct date format. Please confirm how exactly your OS is set and we will try to reproduce and fix the problem. Thanks for pointing out this bug.


#3

My system locale is set for the UK. I’m running Windows 10.

I’ve tried adding more screenshots, but the forum system says that as a new user I can only insert 1 image. Anyway, if you change your system locale to UK, it will be easy enough for you to see in the Windows 10 regional settings the time and date formats that Windows displays.


#4

@Ken_GlassWire, this is an old issue not just in the Usage tab but the Graph and Alert tabs too.


#5

I see no change in v2.0. Even if I enable the setting ‘Use System Time Format’, I still see US dates everywhere in the application, not UK dates.


#6

@harkonnen

Sorry for the problem. Please email us some screenshots if possible and I’ll get this ticket added.
https://www.glasswire.com/contact/


#7

If however, you change the language to a European language, it does change the time format. Unfortunately there in no English (UK) option.


#9

@Glasnet

It’s not related.


#11

Here are some screenshots, from v2.0.102. These are clearly not UK dates.

image

image

image
image


#12

@harkonnen

Is your “use system time format” option checked in your settings?


#13

Yes, Ken. This is not a new bug report.


#14

@harkonnen

Could you try the update we released today, then check it again (check the box in the settings)?


#15

Ken, are you reading what I’m writing? I already said I tried it in today’s release.


#16

Oh, I see now you said .102 from the beginning. I did not officially announce the update anywhere yet, so I was shocked you already had it.

Thanks and sorry about that. I will let the team know.


#17

@Ken_GlassWire Is any actual progress being made on this issue? The latest version, v2.0.112, has still not made any difference.


#18

@harkonnen

In some parts of GlassWire we still don’t use system time, but we are implementing improvements over time.

For you, do you not see the correct system time anywhere in the application or just in some places?


#19

@Ken_GlassWire

Well, it seems to be everywhere. I already gave 4 examples. See my screenshots further up in the thread.