Weird scaling bug on the 2.0 release

I recently installed a clean copy of Glasswire 2 on my only machine (a laptop to be exact). After installing and restarting, the GUI for Glasswire gets scaled so big that I can’t use the program at all. This happens to another machine (my cousin’s to be exact) and the display scale is set to 100% (mine’s set to 125%). Overriding the scale settings on the Compatibility tab fixed it temporarily. As soon as the Glasswire GUI closes, the issue crops up again. And now, the override doesn’t work for it.

Both systems run Windows 10, Version 1709 (Fall Creators Update).



We found this bug and we’ll have a new update out very soon. Sorry about this!

I have the same or similar bug, I recorded a video

Thanks for the vid. We fixed this. Keep tabs on this page to know when the update is out, hopefully tomorrow

The problem is now solved, please upgrade

It’s not fixed


Did you install as a “clean” install with the new version? Can you go to the top left menu and show “About” that shows the version? Sorry for the headache.

That video was recorded in 2.0.80
I just did clean install, didn’t make a difference.
I don’t use any UI scalling in Windows.

@Kapela86, after upgrading, were you able to resize the screen? After doing so, Glasswire re-scaled to normal.

EDIT: Weirdly, a similar issue was on my cousin’s laptop where the Menu portion was misplaced until you resized the window.

What do you mean by “resize the screen”?

I wanted to say “resize the window”. Made a typo in my reply.

I found out why this bug happens. When you exit GlassWire, it doesn’t save maximized window position, it saves it using values from when window wasn’t maximized. And if you manually resize window to full desktop size and then click on maximize, it will store proper values in settings on exit. I recorded a video showing how I “fixed” it
I will be completely honest here: dear developers, stop trying to reinvent the wheel! Why did you have to use some stupid custom windows’ forms, instead of relying on those provided by native Windows API/shell/whatever? I’ve seen this with other software and it’s really annoying. The result is you get windows that don’t behave like normal “windows”. Normal maximized windows behave like this:

  • you can’t resize them from their edges
  • if you move your cursor maximum to upper right corner of your screen and click left mouse button, you will close that window without having to accurately point to X button
  • if you move your cursor maximum to upper left corner of your screen and click left mouse button, you will get a menu with some options.
  • if you press Left Alt+Space, you will get the same menu
  • if you hold Shift and click right mouse button on aplication button on taskbar, you will get the same menu
    NONE of those apply to GlassWire (and there are a few more things) and it’s not consistent with how 99.9% of other apps behave :angry:
1 Like

I totally agree.

Users have been and will continue to be reporting many problems simply because Glasswire is a Windows application that does not follow the Windows guidelines.We lose the use of all sorts of features including the ability to hide the Windows taskbar to save on valuable screen space. If I move the mouse to the screen edge to reveal the taskbar then window resizing pre-empts access to the taskbar reveal. If the window were truly correctly maximised then that would not happen! :rage:

Custom window forms are required by the SDK we use to draw graphs, and for certain parts of our UI. We don’t do it just to be weird, sorry. :slight_smile:

Thanks for the detailed video and help so we can fix it ASAP and we will always try to use default guidelines whenever possible.

So how do other applications use that SDK and get a maximized application window?


I’m not sure, I will find out.