1.2.61b+ Notification problems (Unresolved)

The notification count on the GlassWire icon is “sticking”. Even after I clear the alerts it sometimes remains as in this screenshot.

I had just cleared the alerts for the top two of the three alerts but the icon count didn’t change - it remained 2.

I enabled tray notifications which had been turned off (Settings > “Enable tray notifications” unchecked) so the third alert was then displayed as a notification even though I had cleared it earlier. I cleared that alert again and the icon count disappeared as expected. The top two alerts didn’t display as notifications because “While you were away” notifications were turned on but “Show desktop notification” was unchecked.

I had a similar issue earlier. I can’t remember the exact circumstances but I think that I had cleared the data (Settings > Clear history) when there was an alert and alert indicated by the icon wasn’t cleared.

Reported to the team. Was the alert for one of the remote machines, or for your local machine?

I can’t remember what the alert was but it was on Local. The icon said there was 1 but there weren’t any listed in the Alert tab because I’d cleared the data.

Another issue, which I reported in the past is the duplicate tray icons. They seem to appear after upgrading GlassWire but I’m not sure when they first appear as I didn’t notice them at the time when the install completed. This time I didn’t norice the extra icon until an hour later. I was certain that I’d already run the GlassWire desktop program but maybe I didn’t. Anyway the duplicated generally disappears when I bring up the GlassWire window:

Another GlassWire icon appears after upgrade to a
new version because we are shutting down GlassWire. Windows does not remove
the icon from tray after shut down until user moves the mouse over the
tray. That’s why this “fake icon” does not change the number of the unread alerts.


Why can’t you remove the icon from the tray before uninstalling the old version? Other programs manage to do this.

I will ask the team if it’s possible to do so. I thought it was some kind of Windows thing. What software do you use that removes their icon? I can ask them to try that one as an example.

Actually, I should have said they upgrade without having a second icon. I don’t know if they actually do remove it beforehand. They either:

  • Remove it; or
  • Retain it, which seems much less likely

CCleaner is a good example. I download the installer and run it outside CCleaner. It removes the icon when upgrading. The installer, before exiting like GlassWire, asks me if I want to run the new version.
Download CCleaner free standard version

This issue is resolved in 1.2.64b.

I watched the setup program remove it during the uninstall of the old version.

1.2.64b The issue that has not been resolved is the icon displaying an alert count when all the alerts are cleared.

I have had this sort of problem on both my GlassWire systems.

1. The original problem where alerts are cleared but the notification area icon shows a count.

If I view a GlassWire remote server that cannot connect then the count clears. But if I change to view a GlassWire remote server that is connected then the count does not change.

2. A new problem where the taskbar icon shows a count but the notification icon does not.

I tried all sorts of things to clear the alert count. These are the actions that didn’t work:

  • Alerts were already cleared so there is no button to re-clear them
  • Changed view to all the other tabs.
  • Hide GlassWire from notification area menu
  • Reopen GlassWire from notification area menu
  • Clear all data

What worked to clear the count for the notification area icon was viewing a GlassWire remote server that was not connected. But the task bar icon did not change:

The taskbar icon does change if I close the window or use the notification area icon menu to hide it. But as soon as I show the window again, the icon displays the alert count again.

GlassWire window open:

GlassWire window closed:

GlassWire window re-opened:

3. A new problem where all the alerts are cleared but the “Mark all as read” button remains visible and there is an notification area icon count displayed.

In this case, it says “9+”

4. A new problem where the alert notification count is incorrect.

In this screenshot, I have 7 alerts but only 4 on the the nofication area icon.

I cleared all the alerts and the icon continues to say 4.

Notifications are totally stuffed on both my computers

Strange. I reported this to the team so we can try to recreate this so we can fix it.

:bulb: The notification issues are only happening when I have a GlassWire remote server connected.

One of my computers, MA03, has been hibernating most of the day and I haven’t had any problems while it hibernates. As soon as I woke it and reconnected the first alert on the monitoring computer, MA04, then the icon alert notification wouldn’t clear.

The earlier problems also occurred while both MA03 and MA04 were monitoring each other.

The problem disappeared once the connection to the other computer was lost after I put it to sleep.

We still can’t recreate this but we’ll keep trying. It’s so strange! Thanks for your report.

I decided to start from scratch and see what happens. I uninstalled GlassWire on both computers, deleted the folders in Program Files (x86), ProgramData, and in User AppData. I also removed any registry entries related to GlassWire - there were a lot there back to version 1.

I reinstalled without activating or changing any settings and the notifications were still different for the task bar icon.
On MA03, the task bar and notification area icons match.

On MA04, the task bar and notification area icons do not match.

FYI, the only difference I can find in Windows settings is as shown. This is probably unrelated as both icons appear correctly here.
MA03 GlassWire is Off.

MA04 GlassWire is On:

I changed MA04 to On and it has made no difference.

When I get some time, I’ll see if any of the other problems appear:
First, test after activating and change the settings as usual.
Second, test with the remote connections running.

1 Like

Since the totally clean install, I have only one issue with the notifications. Whereas nothing I tried previously made any difference:

  • Clear history
  • Reinstall
  • Reinstall and clear data.

It is still strange that I got bad installs on upgrading two computers to 1.2.64b from the previous test version.

1 Like

I’ll update the team on this info. Our latest 1.2 versions have been optimized a lot so perhaps upgrading introduced a problem.

It looks like you have enabled option for small taskbar icons on MA04. With enabled small icons Windows just don’t show notification over the application icon.

1 Like

Thanks for pointing that out. I’d forgotten that “Small taskbar buttons” are set on that computer.

I marked this as solved despite the install problems not being resolved because it doesn’t look like they will be easily reproducible without a historic database.