1.2.64b Data not logging (previous title was Usage view not updating)

No, I don’t use torrents of any type.

This was a totally clean install as the conversions left GlassWire with serious problems on both my computers. I had removed every remnant of earlier installs as well.

The services are running.

The only thing that I did differently, which might have a bearing on the cause, was to have the Usage view open at midnight. I say this, because many versions ago I did have problems with change of day.

Strange. Is it not working currently? Please email our helpdesk and I’ll ask the team to investigate.

It turns out that the Graph is affected as well. The slow updating of the Graphs meant that I didn’t notice it last night.

This looks similar to an unresolved issue I reported in the past. That problem also occurred after I had also been doing a lot of different things in GlassWire:

I’m going to restart my system and see if the data is also lost this time.

Yes, GlassWire had stopped logging data just like the unresolved problem with 1.2.57b.

Restarting Windows restarted the logging.

Do you get this problem only once or every midnight?

The problem occurred before midnight, as you can see on the graph, so I don’t think that is related.

Initially, I was reminded of past problems that I had also had with having the GlassWire window open at midnight:

The other time that GlassWire stopped logging data was on an earlier test version, 1.2.57b. The only common thread I have noticed is that the data logging stops after I spend a couple of hours working in the GlassWire window. But it doesn’t stop while I am actually viewing GlassWire:

We are working on trying to recreate this problem. No luck so far, but we’ll keep working on it.

Could you please do following, when (and if) you will get the same problem again:

  1. click on tray menu and select “Exit”
  2. run Glasswire again (via Start Menu or icon on desktop) and check if Usage still empty/broken

I will but I’m quite sure that I tried that the first time and it didn’t restart logging.

The problem has happened again. Coincidentally at about the same time at night:

This time I cannot see when the time when it stopped logging data as clicking on he graph has left it stuck “Loading data”.

Last time this happened, I had GlassWire problems on my other PC. This has happened again:

FYI, I haven’t got the logging version of GlassWire from your helpdesk as @Servo_GlassWire suggested because I’ve taken a break from bug finding.

This time my other computer has stopped logging about 6-7 hours later:

Please email our contact page and we can give you a version that takes logs, then you can email us the logs if you feel comfortable. If you don’t want to it’s OK, meanwhile we’ll continue to try to reproduce this on our end.

I used “Exit” and ran GlassWire again on both computers.

First computer MA04 is stuck visualizing network.
Second computer MA03 says “The GlassWire service stopped running”. The two options to continue don’t make any difference: “(Restart GlassWire)” or “Connect”.

I emailed and was referred to the standard download link - is that right?:

You can download GlassWire from www.glasswire.com, then click “download”.

Oops, I misunderstood your email. I will send instructions to your email address once I hear back from the team.

Is it possible that it is related to the Windows 10 auto-update system as I am experiencing the same problem after an update. And That would explain It stopping at around the same time due too the fact your computer chooses times your not using it to update

1 Like

You might be right as the only event I can see at that time relates to changing the start setting for the Background Intelligent Transfer Service, which is used by Windows Update.


I’m installing the logging version you sent me for both computers I run GlassWire on.

GlassWire has stopped logging data on my MA03 computer which is running the logging version of GlassWire that you sent me.

What now?

Now GlassWire should have dropped some crash dumps on the desktop, did it?

Unfortunately, there is nothing on the desktop: