Glasswire 2.2.291 - Deletes ALL Firewall settings again

Really sounding like a broken record with every new release. After upgrading to 2.2.291 from the previous version, my Firewall tab was blank, everything gone. The “service.backup_2021.02.08-07.35.59” folder that was created had nothing in it, Im assuming its suppose to have a complete backup in there. Luckily for me I do nightly backups and got back my service-full directory. I cant keep doing this process after every upgrade.
Are the owners aware of this issue and the reputation hit this product is taking? Maybe its time to change up the development staff. How many releases have their been since 2.2.258 and yes the exact same “CRITICAL” issue is still there.

1 Like


I am very sorry about this issue.

This issue is caused by an update that was released, then quickly replaced after a few days. Details on what happened are here GlassWire 2.2.291 now available - See process IDs and services - #3 by Ken_GlassWire and that link includes a fix.

Our QA tested with the fix we suggested in the thread linked above and they found it solved the issue. I hope it will solve the issue for you also?

Thanks for your patience with this problem.

I agree it is unacceptable that this happened and we put out a fix within days once we determined the problem. If you can implement the suggested changes in the threads above it should solve the problem for your permanently.

Again, I apologize for the issue that this caused.

Did you seriously just give me some trashy insulting canned response? You know I was the one who first reported this issue and the one who first tested that band aid fix. All this is is a way to get those settings back after the update blows them away. What I am demanding at this point is a permanent fix so I dont have to follow that damn procedure every time there is an update. I want to run the update, have it install, start the program and have all my firewall setting there. Thats not happening, STILL.


I’m very sorry to hear you thought my response was canned? We don’t use canned responses here. I am a real person trying to do my best to help you.

This is a public forum, so when I reply to people with issues I will:

  1. Give detailed information about the issue and how it happened.
  2. Give detailed information on how to solve the problem.

I will admit I did not remember that you were the original person to post this issue and I apologize for that. Me making this detailed post was not intended to somehow be some kind of insult to you in any way. But instead, I was trying to save others in the future from having to figure out the solution of this problem by searching through the forum again for all the answers.

This recently came up for another user who was also very frustrated with this issue. We apologized for the issue, and then our QA tested a fix and found it solved the problem for us.

I just reviewed the instructions:

Could you give these instructions a try (even if you must do so a second time)?

Stop the GlassWire Service in Windows services and the GlassWire UI.
Open C:\ProgramData\glasswire
Rename the existing service-full directory to service-full-backup.
Make a copy of the existing service.backup_2020.10.XX-XX.XX.XX and rename it to service-full
Run notepad.exe as administrator and open C:\ProgramData\glasswire\service-full\glasswire.conf
Set DbStorageDirectory = C:\ProgramData\glasswire\service-full and save changes.
Run GlassWire service.
Run GlassWire.exe. The history, configuration, firewall rules should be restored.

I should have noticed in that old thread that you did implement that change, but you continue to have the issue.

I have escalated your issue and our team just now asked if it was possible to try the fix one more time? We request this because our QA tested the fix and found that it solved the problem.

Also our team asked if you store your GlassWire settings or database on a secondary drive? Perhaps this is why the fix is not solving the problem for you permanently.

1 Like

Ken, read man please read, from my original post: " Luckily for me I do nightly backups and got back my service-full directory. I cant keep doing this process after every upgrade." I did do those instructions, Im all to familiar with them. I use the default installation, no custom drives or folders.
I install the program, after installation, run it, click on firewall tab, and its empty.
In the C:\ProgramData\glasswire, the backup folder that is created during installation is empty. The service-full folder starts off empty and starts building from scratch.

I agree, you should not have to do this after every upgrade.

Our QA tested and they found that making the change, then updating with our most recent version solved it for them. If you make the change again as listed here Updated to 2.2.258 - all settings gone - #21 by Ken_GlassWire one more time our testers found it solved the issue. They installed the version with the bug, then made the change, then installed our latest version.

When did you last implement this fix? Updated to 2.2.258 - all settings gone - #21 by Ken_GlassWire Did you try it recently or was it only when the bug first happened?

Sorry for the issue and thanks for your patience.

My frustration level is through the roof right now. Are you just simply not understanding what I am typing?
This is from my original post:
"Really sounding like a broken record with every new release. After upgrading to 2.2.291 from the previous version, my Firewall tab was blank, everything gone. The “service.backup_2021.02.08-07.35.59” folder that was created had nothing in it, Im assuming its suppose to have a complete backup in there. Luckily for me I do nightly backups and got back my service-full directory. I cant keep doing this process after every upgrade. "

Please pay specific attention to the bolded text. Correct me if I am wrong here, but when a person goes to install the program, a backup folder is created of the service-full directory and it is named something like service.backup_2021.02.08-07.35.59, that should contain exactly what was in the service-full directory correct? And what I have told you numerous times including my original message is that directory is empty, blank, 0 bytes, zero bytes, nothing in it. I also have stated that I manage to get things back up and running by following some of that procedure, obviously the stopping of the processes in order for me to manipulate the directories. I recovered the service-full directory not by using your empty blank backup, but by using a nightly backup of my own and just copying that folder back over and restarting the GW processes. I also mentioned that in the original post.

The issue is 2 things, you are creating a empty backup folder, and you are blowing away all the data in the service-full directory. My guess is that you are blowing away the data first, then creating a backup of that already empty directory.

Sorry for the issue. I will share your post with our team and see if they have a suggestion.

Our QA is unable to recreate the issue so it makes it difficult to suggest a solution.


I gave up trying to explain the issue to the GlassWire team. They broke our installations with version 2.2.258. As you know (and as as GlassWire should know), the upgrade process that that version performed is what broke things.

I even tried bringing up the issue again in this thread:

But @Ken_GlassWire demonstrated that GlassWire themselves still don’t actually even understand the problem. They thought that by having their QA do a CLEAN/FRESH install of 2.2.258 they’d be able to replicate the problem. Nevermind that you and I and others have been pointing out for months that the problem is that the UPGRADE to 2.2.258 broke EXISTING installations (prior to version 2.2.258) that already had a lot of data.

The last few upgrades since then have completed wiped out all settings each time. Even the latest version, 2.2.291, which I recently upgraded to, left me with a completely empty backup folder. In other words, the previous settings/data are actually not backed up successfully at all. They just get completely wiped out (deleted). The only way I’ve been able to restore my settings each time is to restore the appropriate folder from my own backups.

So the summary is, GlassWire released a defective version, borked our existing installations (us, the people who actually reported the problem to them), and then never found a solution to solve the problem permanently or properly for us. The instructions that @Ken_GlassWire keeps parroting, which he claims can “fix” the issue, are of no use – firstly, the problem happens after every upgrade, and secondly, the backup folder is empty after each upgrade to a new version – there is nothing there.

After months of hassle and getting zero actual understanding from the GlassWire team, I’ve realised it’s something they’re never going to get their heads around and something they’re never going to fix.

A couple of days ago I decided to just do a complete uninstall, then deleted the remaining Glasswire-related directories manually, rebooted, and did a fresh install of v2.2.291. It’s been a major hassle for me, as I’ve been having to manually track down which devices are which on my network again (which MAC addresses are which devices), and re-enter all the labels for my Things list, etc. But I had no choice, as the GlassWire team were completely unable and unwilling to provide a real, permanent solution.

I am very sorry for the issue with our previous version. Today I have been installing 2.2.258 (the version that had this bug) and the different GlassWire versions immediately after in different orders to try to recreate the issue myself to share with our team so we can diagnose and help. I have tried on my own PC, and a VM.

I will keep trying different installation orders and methods to try to recreate the issue.

No it didn’t.

So… instead of going backwards to find out what went wrong in the upgrade process from 2.2.241 to 2.2.258, and then looking at what was fixed in 2.2.260 (compared to 2.2.258) so that you can undo the damage that the 2.2.258 upgrade did, you’ve instead decided for some reason to go forwards and start testing from 2.2.260 onwards. LOL. This is why I gave up trying to communicate the issue with you. You and your “QA” truly are hopeless.

Anyway, I’ve got a fresh install now, which came at great inconvenience to me. Too bad that others are in the situation too where they were unlucky enough to have upgraded to 2.2.258 at one point, and now forever will have broken installations until they also decide to just bite the bullet and fresh reinstall.

With the GlassWire team trying to “help”, it’s basically the blind trying to lead the able.