Updated to 2.2.258 - all settings gone

@Anjoland @krevvy

Could you guys send me a screenshot of the folders you see here? It will help us diagnose the issue.
C:\ProgramData\GlassWire

If you want to send it to me privately just click my name in the forum, or email it to me and include a link to this forum post so I know what it’s about. https://www.glasswire.com/contact/

I upgraded to 2.2.241, but that had the issue of devices not appearing on the Things tab, so I went back to
2.2.210. So I upgraded from 2.2.210 to 2.2.258.

That directory has 3 sub folders. Service, Service-Full and Share.

1 Like

Forgot also has, service.backup_2020.10.06-09.52.01 and service.backup_20200530_225348

1 Like

The info is shared with our team, very useful, thanks! Again I apologize.

For the heck of it, I added some items to the blocked apps and I reinstalled the program and sure enough it wiped out all of the just added blocked apps.

1 Like

@Anjoland @krevvy

We should be able to help you restore your previous settings. Could you give these instructions a try?

  • Stop the GlassWire Service in Windows services.
  • Open C:\ProgramData\glasswire
  • Rename the existing service-full directory to service-full-backup.
  • Make a copy of the existing service.backup_2020.10.XX-XX.XX.XX and rename it to service-full
  • Run notepad.exe as administrator and open C:\ProgramData\glasswire\service-full\glasswire.conf
  • Set DbStorageDirectory = C:\ProgramData\glasswire\service-full and save changes.
  • Run GlassWire service.
  • Run GlassWire.exe. The history, configuration, firewall rules should be restored.
2 Likes

Good news, followed those steps and it worked. Thanks. All settings are back.

1 Like

@Anjoland

I’m glad it’s fixed for you! We are still working to recreate this problem after install so we can figure out why it happens to some people and not others.

@krevvy

What previous version of GlassWire did you use before this one?

Same issue for me. I’ve just upgraded from v2.2.241 to v2.2.258 and it’s like it’s a fresh install. All my history, all my alerts, etc. are gone. Used the full version installer, and definitely didn’t choose to do a fresh install or to reset the Windows firewall rules.

Sorry @harkonnen. Can you try these instructions? It solved the issue for another person.

I’ve done those steps and that has restored the descriptions of my devices on the Things tab, and it has restored the list of alerts on the Alerts tab, which are the things I’m most concerned about. But it didn’t restore the historical data for the Usage or the Graph tabs.

Hi… I was on v2.2.241 and perfoming the upgrade to 2.2.258 wiped out the settings…

I manually just allowed/blocked the required apps so didn’t bother trying the restore method.

As a test I have just tried
2.2.258 full with settings in place… Then installed the 2.2.258 lite over the top and it also wipes out settings…
(Your blog post specifically says it will retain settings)

At least we know how to restore settings now! Hope you manage to get it fixed before too many people get hit by this issue.

@krevvy

I updated the GlassWire Lite Blog post so it’s more clear. It’s correct that your history/settings will change when using GlassWire Lite (the installer even warns about this) but you can switch back to GlassWire Original and all your settings and history should return.

Ah ok… I only tried the lite on one of the laptops (after the full version had already lost most settings on it)…
Ive left the full versions on the other 2 machines and manually reconfigured the settings
Cheers

@krevvy

Sorry, I think my writing was not clear enough so I improved it so nobody is confused in the future. Also we added a warning in the GlassWire Lite installer window itself, but perhaps it’s too easy to miss.

I downloaded via green download button on main page, left all settings on default and same thing happened here as previously reported; settings restored by following instructions above.

1 Like

@grahampembs

Sorry about that. Do you recall the previous version of GlassWire you had before this one?

I’m sure it was the version immediately prior to this one - 221? as I update as soon as new version becomes available.

1 Like

Just checked other machine which has version 241 so must have been that version on this pc too which I just updated.

1 Like