GlassWire upgrade alert - Trouble updating to the latest version (1.2.64b)? Click here!


#1

Tonight we plan to alert all our GlassWire users to upgrade to the latest version (1.2.64b). During the upgrade process GlassWire should convert your database to a new version, but if you run into a problem during this conversion like a freeze there is a solution.

Instructions:

Go to add/remove programs and uninstall GlassWire. Next reboot. Are you OK with losing your database history? If so please download the latest version of GlassWire again from www.glasswire.com and choose the “clean install” option with the installer. If you aren’t OK with losing your history you can choose not to use the “clean install” option.

Please note choosing “clean install” shouldn’t change your paid/free status.

If this doesn’t work for you post to this thread so we can help you. Thanks for upgrading and sorry for the problems. This update is a major upgrade that should use significantly less resources. You can read about the update here https://blog.glasswire.com/2016/03/29/how-glasswire-1-2-saves-your-memory-and-resources/.


pinned globally #2

#3

I think getting everyone to upgrade is a good idea – thanks. But nowhere in your information do you say that the new release is 1.2.64b – that should be specified. Also, you should reiterate that users can check their release level by clicking Glasswire on the title bar and then About.

I think this is worth editting the post above.


#4

I updated the post above, thank you!


#5

No issues here Win 10 x64 running very nice.


#6

I have also been having a problem when I tried to install the update. It did not install. I got and error opening file for writing. to retry or ignore does not continue and it also does not abort. After finally getting it to stop I can no longer start the old version. I will try to uninstall it and reinstall. But this will effect my registration and have to have it reset. But wqill try anyway.


#7

Uninstalling the old version an installing the updated version did work and I was able to the registration number back in without a problem. I had to do this on all of the machines that it is installed on. I would suggest to all that are having problems updating to uninstall the old version first and the download the newest version and install it.


#8

The latest update is completely broken for me, at first I tried just updating from the previous version which went perfectly but upon it starting it completely locked up, caused several services within Windows to crash along with Windows Explorer crashing every time I went near the task bar.

If I closed GlassWire, the issues would stop but I still needed to restart my PC to fix all the services that crashed. Next I tried a completely clean install which went slightly better but I still ran into the same issues with services crashing etc.

Is there a link to the old version as it worked perfectly for me?


#9

I tried to upgrade to the latest version. The installer gets stuck at converting database and sits there for hours. I have to end task to get it to stop. Trying this multiple times does nothing. Tried uninstalling, but in Control Panel programs, it lists every program I have except GlassWire. GlassWire is nowhere to be found except ProgramFiles X86\Glasswire. Any other suggestions? Help!


#10

After uninstalling, go to the ProgramData subdirectory and delete the Glasswire subdirectory that is under it. Reboot and re-install Glasswire.

This is similar to doing a manual clean install, but you are ensuring there are no remnants.


#11

Yep, didn’t event hink to check ProgramData. That seems to have fixed the issues for me.


#12

My tray icon totally not work on my Windows 10 x64. I can see the icon, but click on it will never get any response. The only way to open the main window is to double click the desktop shortcut of GlassWire again.


#13

@Orange Did you upgrade to our latest version? Can you try a clean install? Also can you check the hidden items in your tray and see if perhaps there is a second hidden GlassWire icon?


#14

I tried everything and exhausted all my options. Got tired of watching the upgrading database message sit there for hours on end. So, I just did a clean install and problem fixed. Lost all my history, but at least it’s working again.


#15

I would suggest that there is no need at all for anyone to watch the upgrading database message for hours. Even with a six month database, the upgrade took minutes, not hours. The longest I waited for the conversion was a half hour and that only before I was able to confirm that the time needed is typically minutes. If you have a database extending to the earliest days of Glasswire (very few do, I expect), I would expect 15 minutes would probably be long enough for the conversion.


#16

@richlife69 is correct. The conversion should not take hours, and if it is then something must have failed unfortunately.


#17

I also suddenly have this problem reported by Orange above after upgrading from 1.1.41 to 1.2.64b. Right, left or double clicking tray icon does nothing on Windows 10 x64 glasswire free version. I attempted both upgrade and then when hit this problem, a clean install but problem contines. can still open Glasswire via the start menu however. Thanks.


#18

@fhkmzb Reported to the team, thanks. Very weird.


#19

@fhkmzb @Orange We think we found this problem. Can you install the latest Windows Updates and see if it solves the problem? If it does not can you change your Windows Defender Settings to the following below and see if it solves it where real time protection is off temporarily? Then see if turning off real time protection solves the problem so we can confirm that’s what the issue is.

Of course you should probably turn on real time protection again when you’re done.


Unable to uninstall GlassWire
#20

My Win10 was already up to date with the latest, so that was not a factor. Turning off Windows Defender real time protection did fix the problem. Note however that I had to turn off real time protection and then exit and restart Glasswire for the tray icon to begin working as expected, turning off real time protection on its own did nothing.

I would only add that version 1.1.41 did not have this problem, if that helps pinning down a fix for this issue, thanks.