Messing DNS and huge conflict with NordVPN


#41

Oh and to explain why I think this can be resolved by GlassWire, THE VAST MAJORITY OF MY APPS WORK RIGHT WITH GW, like 99.9%. So I don’t believe that anything else in interfering.


#42

I thought I was winning. I reset Windows Firewall and removed the alerts DB from GW. Started everything up. It was working like a dream. Even faster connections to the VPN, no intermittent hangs in connectivity. IPs verify that I’m tunneling. Ask to Connect prompts show up for Nord and OpenVPN. Then I rebooted. Right back where it was. So i try over and over, I am patient for the connection to come up. Nothing. I notice GW shows no traffic through NordVPNClient.exe, I recreate my outbouud firewall rule. It works again! But GW still shows no traffic through the exe i just allowed out. I will now try the above uninstall reinstall process.

Side note: Several apps are being blocked on reboot without prompting to allow. I must uncheck the fire button by each of them. It seems to be different ones each time I reboot after removing the GW Alert DB. Too many boot time services bombarding GW?


#43

Sorry to report that after trying the suggested uninstall and clean reinstall the problem is still an issue. It seems to work before a reboot. It seems to let me on to a tunnel once and then not again. For the first time I needed to create both inbound and outbound firewall rules. On occasion the vpn will work for a moment then stops. I have watched what VPN servers I am connecting to to see if it is tunnel specific, it is not. I am now receiving incorrect login errors from my VPN client as if the auth packets are being corrupted. I am now having trouble with multiple videogames not being able to connect despite allowing them through GlassWire. Call me cray cray but I think we have a problem here. Oh and I too rebooted and logged off multiple times to see if other apps would ask to connect. The ones that beat glasswire and were blocked, I deleted them from the firewall list in GW and then they did in fact ask again. This was an attempt to not use the fire button as I did before.

Side note: Turning the firewall on and off in GlassWire seems to be unreliable. It will turn off at times, but other times it keeps on blocking apps until a firewall rule is created. Resetting the windows firewall with GW Services off solves the problem also.


#44

Oh and I have used glasswire for around 2 years. This began once I started using the Ask To Connect feature.

Windows 10 Pro / Windows Firewall with Advanced Security
Windows 7 Pro / Windows Firewall with Advanced Security

Does it have something to do with Windows Firewall with Advanced Security?

UPDATE: Click To Block mode seems to work very well. I’m just going to keep it on that for now.


#45

@thevectorinspector Strange. We’ll try to reproduce this again.

Sorry if we already asked, but what’s your OS/setup so we can test for this again? Do you have anything unusual running besides GlassWire that could be network related?


#46

Well I am running in single user mode on a domain computer with local admin rights. The OS is now Win10Pro was Win7Pro. Both had Avast. Win7 was running Avast with firewall (disabled), currently running windows firewall only and Avast AV (SecureDNS disabled). I am using Malwarebytes now but wasn’t before. Both were using Windows Defender. It’s an i5 proc, 8GB ram, Intel NIC, legit #nopirate. Wired 1gig network. I use a /23 netmask. I have an IPS in the network.

Can I ask how GW hooks into the traffic? I notice that it does not make Win Firewall rules. Does it “middleman” the traffic and allow/disallow routing or does it invisibly add and remove firewall rules?


#47

@thevectorinspector

GlassWire uses the Windows Firewall API. We don’t middleman anything with blocking. We use a Windows API to see network data, so we don’t middleman anything there either.

If you disable Avast completely (not just DNS) does it make any difference? Maybe it has something to do with their DNS changes?

I will let our dev team know your setup so we can continue to try to reproduce this.


#48

@Ken_GlassWire
I forgot to clarify that. I have had it without Avast installed and the same thing while using BitDefender for a month.


#49

Hi, I joined today just to let you know that I have also been experiencing the issues as the other users in theis thread with NordVPN and glasswire.

I use windows 10 and the free version of glasswire - I use AVG antivirus.

Problem started for me over a month ago - the nord client would say I was connected, but I was unable to connect to any website.

I spend an afternoon with Nord Support who were unable to resolve the issue and i was unable to connect with the Nord App - I then started to use the OpenVPN client to connect to Nord - this worked fine until recently (last week?) - now the same happens with the openvpn client.

I decided to try a test on my laptop which also runs win10, and has never had glasswire installed and the nord client works fine.

back to problem desktop - I closed Glasswire using the taskbar icon and still was unable to connect, I then killed all memory processes related to glasswire, and now Nord client is working and i can connect to websites again…

having identified glasswire as the problem i did some googling and ended up on this thread…

hopefully you can findout why this is happening :slight_smile:

thanks


#50

NordVPN gave us an account to test with and now our QA team will test again and see if they can recreate it. Our dev team already tested and couldn’t recreate it and neither could I. It’s frustrating!


#51

Just found this thread - same issue here; Windows 10, NordVPN + Glasswire and no connectivity after trying to log in. Installed the newest TAP driver, disabled IPV6, allowed incoming/outgoing traffic for NordVPN in Win firewall rules, messed with DNS settings, etc. Nord + Glasswire coexisted fine until about the middle of September, and I assumed it was one of Windows 10’s wonderful forced updates. I am able to establish a PPTP VPN connection from another service (free through Usenet provider) directly through Win 10, but NOT an L2TP connection to a NordVPN server IP provided by their tech support. Really REALLY don’t want to uninstall Glasswire as I rely on it for granular control over the constant Windows 10 metrics spying. But if it’s keeping me from using the service I paid for I may have no choice. Another data point; I tried VyprVPN on a 1-week trial and their client connected just fine w/Glasswire. Looking forward to a possible resolution from the Glasswire folks if they can duplicate it…


#52

@Tim_Baker

We released an update this morning. Want to try it and see if it still has the problem?

Please note though, we were unable to recreate this problem on our own machines so this update has no changes with regards to NordVPN.

Maybe try this:

Uninstall GlassWire, reboot, then go to your “Firewall” control panel in Windows and choose “restore defaults”. Next install GlassWire again using the “clean” option with the installer. Let us know your results.


#53

Thanks Ken - will do! I’ll report back…


#54

We have fixed the problem. If you want to test a new version of GlassWire please email us with “nordvpn problem” as the subject.
https://www.glasswire.com/contact/


#55

So what caused the problem?


#56

@Remah

We’re not 100% sure yet, but when I know I will let you know here or privately.


#57

Thank you. I am intrigued how it could happen.


#58

@Tim_Baker @dash @thevectorinspector @paddy

The problem is now fixed:


#59

I can confirm the new custom version works correctly with NordVPN without any problems. I just wonder how many changes have been made as the older version logged the IP change or DNS change, the custom version seems to not log it anymore. Any reason for that please?


#60

@paddy

I will ask. I think it’s because this is an unreleased test version.