Messing DNS and huge conflict with NordVPN



We just tested this case and noticed that NordVpn changes the DNS server address when we connect for the first time and GlassWire logged this for us, but it appears it does not restore the original DNS server addresses when we disconnect it. That’s why there is no alert for the DNS server address changes.

We think the behavior for GlassWire is correct.


That makes two of us! Sounds like they found a winner!


This problem is now fixed with GlassWire 1.2.79 and any future GlassWire versions. To fix it download GlassWire’s latest version, then create a “glasswire.conf” file with your Notepad application.

Inside the GlassWire.conf text file created by Notepad please insert this text.

hostname_enable_nslookup = false

Please move the .conf file to C:\programdata\GlassWire\service

Reboot your PC.

Now the problem should be fixed. This .conf file disables GlassWire host lookups. For some reason NordVPN would block all network activity if GlassWire tried to do a lot of host lookups and this was the only solution we could find. We reported the problem to NordVPN.

Thanks for your patience and feedback so we could solve this problem!

NordVPN + GlassWire
What to try if your 3rd party VPN won't connect
Breaks internet


I might be having the same issue.

There is no C:\programdata\GlassWire\service on my computer

Did you mean: C:\Program Files (x86)\GlassWire ? There is no service folder in there either.



Sorry for the confusion. Please check this helpful article to find where your programdata folder is located for your OS version.


Thanks, I found the correct folder.

However there’s already a glasswire.conf file in there, can I just overwrite it with this hostname_enable string?

edit: I’ve just added the file as the other .conf file lacks the extension so it didnt ask to overwrite. It seems to have fixed the issue.


Aaaaaaand the problem is back. Still cant use GlassWire with nordvpn


You need to restart the GlassWire service also after you add the config file. Did you restart the service? Rebooting may help also.

Also maybe check the VPN when GlassWire isn’t running at all. Perhaps the VPN is just down and it has nothing to do with us.

Upgrading to GlassWire 2.0, tips, tricks, bug reports, feedback, and fixes

Yes I’ve rebooted after adding the conf file

I think it worked for a while because GlassWire wasn’t actually running - it was showing the service disconnected window.

Upon rebooting and activating NordVPN, nothing would load. Quitting glasswire and exiting the two other glasswire processes in the task manager it worked again…

Do I need to delete the other conf file I mentioned earlier?


You need to update the config file that’s already there, then remove the other one. Sorry for the confusion.