Messing DNS and huge conflict with NordVPN

Just found this thread - same issue here; Windows 10, NordVPN + Glasswire and no connectivity after trying to log in. Installed the newest TAP driver, disabled IPV6, allowed incoming/outgoing traffic for NordVPN in Win firewall rules, messed with DNS settings, etc. Nord + Glasswire coexisted fine until about the middle of September, and I assumed it was one of Windows 10’s wonderful forced updates. I am able to establish a PPTP VPN connection from another service (free through Usenet provider) directly through Win 10, but NOT an L2TP connection to a NordVPN server IP provided by their tech support. Really REALLY don’t want to uninstall Glasswire as I rely on it for granular control over the constant Windows 10 metrics spying. But if it’s keeping me from using the service I paid for I may have no choice. Another data point; I tried VyprVPN on a 1-week trial and their client connected just fine w/Glasswire. Looking forward to a possible resolution from the Glasswire folks if they can duplicate it…

@Tim_Baker

We released an update this morning. Want to try it and see if it still has the problem?

Please note though, we were unable to recreate this problem on our own machines so this update has no changes with regards to NordVPN.

Maybe try this:

Uninstall GlassWire, reboot, then go to your “Firewall” control panel in Windows and choose “restore defaults”. Next install GlassWire again using the “clean” option with the installer. Let us know your results.

Thanks Ken - will do! I’ll report back…

We have fixed the problem. If you want to test a new version of GlassWire please email us with “nordvpn problem” as the subject.
https://www.glasswire.com/contact/

1 Like

So what caused the problem?

@Remah

We’re not 100% sure yet, but when I know I will let you know here or privately.

Thank you. I am intrigued how it could happen.

@Tim_Baker @dash @thevectorinspector @paddy

The problem is now fixed:

1 Like

I can confirm the new custom version works correctly with NordVPN without any problems. I just wonder how many changes have been made as the older version logged the IP change or DNS change, the custom version seems to not log it anymore. Any reason for that please?

@paddy

I will ask. I think it’s because this is an unreleased test version.

@paddy

We just tested this case and noticed that NordVpn changes the DNS server address when we connect for the first time and GlassWire logged this for us, but it appears it does not restore the original DNS server addresses when we disconnect it. That’s why there is no alert for the DNS server address changes.

We think the behavior for GlassWire is correct.

That makes two of us! Sounds like they found a winner!

1 Like

This problem is now fixed with GlassWire 1.2.79 and any future GlassWire versions. To fix it download GlassWire’s latest version, then create a “glasswire.conf” file with your Notepad application.

Inside the GlassWire.conf text file created by Notepad please insert this text.

hostname_enable_nslookup = false

Please move the .conf file to C:\programdata\GlassWire\service

Reboot your PC.

Now the problem should be fixed. This .conf file disables GlassWire host lookups. For some reason NordVPN would block all network activity if GlassWire tried to do a lot of host lookups and this was the only solution we could find. We reported the problem to NordVPN.

Thanks for your patience and feedback so we could solve this problem!

4 Likes

Hi

I might be having the same issue.

There is no C:\programdata\GlassWire\service on my computer

Did you mean: C:\Program Files (x86)\GlassWire ? There is no service folder in there either.

@GalakFyarr

Sorry for the confusion. Please check this helpful article https://www.howtogeek.com/278562/what-is-the-programdata-folder-in-windows/ to find where your programdata folder is located for your OS version.

Thanks, I found the correct folder.

However there’s already a glasswire.conf file in there, can I just overwrite it with this hostname_enable string?

edit: I’ve just added the file as the other .conf file lacks the extension so it didnt ask to overwrite. It seems to have fixed the issue.

Aaaaaaand the problem is back. Still cant use GlassWire with nordvpn

You need to restart the GlassWire service also after you add the config file. Did you restart the service? Rebooting may help also.

Also maybe check the VPN when GlassWire isn’t running at all. Perhaps the VPN is just down and it has nothing to do with us.

Yes I’ve rebooted after adding the conf file

I think it worked for a while because GlassWire wasn’t actually running - it was showing the service disconnected window.

Upon rebooting and activating NordVPN, nothing would load. Quitting glasswire and exiting the two other glasswire processes in the task manager it worked again…

Do I need to delete the other conf file I mentioned earlier?

You need to update the config file that’s already there, then remove the other one. Sorry for the confusion.