The GlassWire service stopped running

I got a problem with glasswire. since september it stopped working.
"The GlassWire service stopped running."
i hoped that updates will fix the problem, but it is still not working.

i tried following things:

-Reinstall GlassWire
-Reinstall GlassWire + delete C:\ProgramData\GlassWire
-changed various settings in the windows service “GlassWire Control Service”

still dont work. is there any other solution to fix this problem?

Im using Windows 10 x64

Please right click the taskbar and choose “task manager” then “Services” and right click the GlassWire Control Service and start it manually. Is it possible your antivirus is blocking GlassWire? What antivirus do you use?

The service is running, i also tried to restart it. the service is running but it seems that glasswire is unable to “connect” to the service.
im using eset nod32 antivirus. but i use that a long time together with glasswire, worked fine.

Same issue here too. Maybe some conflict with ZoneAlarm?

If you temporarily remove ZoneAlarm does GlassWire work?

I need to make a test. I’ll let you know.

i tried to disable nod32, does not help. in 1 of 10 times i reboot my pc, glasswire works. in the other 9 times it stay grey in the taskbar and shows “the glasswire service stopped running”. i will reinstall my windows today, hope it will work then :smile:

We released an update this morning. Please try a clean install of this new version.

With new version I have problems too. In my case it’s related to ZoneAlarm. Disabling it make Glasswire to run. Once started it run also with ZoneAlarm enabled. But if I make a logoff-logon cycle then it stop again.

Old version said “unable to connect” while the new one say only “connecting”.

If you don’t use ZoneAlarm GlassWire works with no problems? We will test with ZoneAlarm and try to recreate this.

I kept pc without zonealarm for 1 day and no problem, I reinstall it and glasswire worked until I made a logoff-logon sequence. Then tray icon was grayed and GUI was showing “connecting”.

Just to be more clear: services seems to be working even if GUI think not. I say this beacuse when in some way I make it run again I can see traffic graph also for time it was “inactive”.

I’m running windows 8.1 pro 32 bit. Had issues with GlassWire “Not responding” after launching it. Continued for few days. Had enough of it. Uninstalled it, removed from Program Data as well, rebooted, installed the latest v1.39. Still same issues, and then it stops working while i’m doing other things on computer.
I’m running Avast anti virus, and no other firewall conflicting.
I think there is a bug in the latest version, and previous versions. I’m getting forced to use another firewall prog.

I’ve also had what seems to be the same problem with GlassWire. It has not started correctly twice since using the latest version 1.1.39. It is working after I reinstalled the same version.

Other changes may be related to the issue:

  • I’ve had to install Windows 10 v1511 by resetting Windows.
  • I’ve changed antivirus from Avira Free to BitDefender Home Free.
  • Both times I’d used CCleaner to free up disk space and uninstall programs before restarting Windows.

Another issue arose this morning when GlassWire had started and appeared to be running correctly. A second grayed out GlassWire icon was visible in the notification area (previously called the system tray) to the left of the colored icon. I only saw it for a second after the taskbar appeared so I might have been mistaken. the grayed icon may have been there for a lot longer but my taskbar is set to autohide so I didn’t see it. Unfortunately I wasn’t quick enough to copy the screen before it was gone.

I reinstalled Windows 10, now it works fine. But i also think that there is still a problem with glasswire itself.
Im now using exact the same programs (which maybe can affect glasswire) as before (ESET nod32, windows firewall, glasswire) but now it works.

1 Like

Few days with no problem here…

1 Like

I have the same problem . I downloaded GlassWire today . But in Services the GlassWire Control Service is stopped , i try starting it but it stops. I tried everything ! Please help

Please uninstall GlassWire, reboot, then reinstall our latest version with the “clean” option.

I Had the same issue after install Adguard, even disabling and turning off Adguard, GlassWire were unable to connect and service stoped. Then I openned Adguard and stablished a filtering exeption for GlassWire, and that works. I hope problem was solved.

1 Like

i find change mon bios ! recycler.bin system colume information win7 64

We recommend the above. Sorry for the problem!